Slow Internet Connectivity

Major incident Broadband4 Internet Services for Education Broadband4 Leased Line Services Broadband4 Filtering Services Broadband4 FTTP/FTTC/ADSL Services
Mon 17 Apr, 2023 10:23 BST · 1 week, 2 days, 23 hours, 30 minutes

Updates

Resolved

Issue resolved.

Tue 18 Apr, 2023 · 22:51 BST
Monitoring

Service has stabilised and engineers are continuing to monitor. A further update will be posted when this incident is regarded as resolved.

Mon 17 Apr, 2023 · 11:01 BST
Investigating

We are seeing slow internet speeds across the Broadband4 network, engineers are currently investigating.

Mon 17 Apr, 2023 · 10:25 BST

← Back