Slow webpage loading

Minor incident Broadband4 Internet Services for Education Broadband4 Leased Line Services Broadband4 Filtering Services Broadband4 FTTP/FTTC/ADSL Services
Wed 13 Dec, 2023 09:00 BST · 1 day, 12 hours, 30 minutes

Updates

Resolved

No further issues observed.

Wed 13 Dec, 2023 · 18:01 BST
Monitoring

We have observed degraded service for some customers when loading certain webpages. This relates a short period of degraded service observed yesterday at around 2pm. This coincides with the release of an update for ChromeOS and the Chrome browser on all platforms. Unfortunately, Google decline to stagger their update deployments, resulting indescriminate client updates across customer networks, outside the control of end-users.

The issue appears to have subsided, but engineers are continuing to monitor the situation.

Wed 13 Dec, 2023 · 09:54 BST

← Back