Internet performance

Minor incident Broadband4 Internet Services for Education Broadband4 Leased Line Services Broadband4 Filtering Services Broadband4 FTTP/FTTC/ADSL Services
Mon 15 Apr, 2024 08:39 BST · 3 days, 1 hour, 31 minutes

Updates

Resolved

No further issues observed.

Mon 15 Apr, 2024 · 10:00 BST
Issue

We are aware of internet traffic issues affecting some customers on Broadband4 this morning. Engineers are currently investigating.

Mon 15 Apr, 2024 · 08:39 BST

← Back