Outbound calls failing for some customers

Major incident MyCloud Services MyCloud Voice Services
Thu 19 Sep, 2024 11:37 BST · 1 hour, 54 minutes

Updates

Resolved

This was identified as a problem with an upstream provider. The provider has since resolved the issue, and outbound calls are now working correctly.

Apologies for any inconvenience caused.

Thu 19 Sep, 2024 · 13:29 BST
Issue

We’re aware of an issue currently affecting outbound calls for some customers. We’re currently investigating and will update this post when we have further information.

Thu 19 Sep, 2024 · 11:37 BST

← Back