Inbound calls
Major incident
MyCloud Services
MyCloud Voice Services
Wed 22 Jan, 2025 08:23 GMT
· 1 day, 7 hours, 53 minutes
Updates
Resolved
Thu 23 Jan, 2025 · 16:00 GMT
No further occurrences of this issue have been observed since yesterday’s update and this incident will now be closed.
Please accept our apologies for any inconvenience caused.
Monitoring
Wed 22 Jan, 2025 · 09:33 GMT
The issue with inbound calls should now be resolved, with calls flowing normally again.
Engineers will continue to monitor for a period. If you observe any continued issues with inbound calls, please notify the helpdesk so we can investigate for you.
Issue
Wed 22 Jan, 2025 · 08:23 GMT
We are aware of inbound calls issues this morning. Engineers are investigating and liaising with one of our upstream providers at the moment. We will post a further update shortly and apologise for the service disruption.
← Back