Broadband4 Issues

Major incident Broadband4 Internet Services for Education Broadband4 Leased Line Services Broadband4 Filtering Services Broadband4 FTTP/FTTC/ADSL Services
Mon 24 Nov, 2025 08:13 GMT · 1 hour, 4 minutes

Updates

Resolved

The fix mentioned in the previous update has resolved this issue and there have been no further incidences observed.

Everything should be functioning as normal as of our last update. If you are continuing to experience issues, please reach out to our helpdesk, so this can be investigated for you.

Apologies for any inconvenience caused by this outage.

Mon 24 Nov, 2025 · 09:16 GMT
Monitoring

The potential root cause of the issue has been identified and a fix implemented. Engineers will continue to monitor.

If you notice continued issues after this update, please notify us so we can investigate further.

Mon 24 Nov, 2025 · 08:20 GMT
Issue

We are aware of connectivity issues affecting some customers this morning and engineers are currently investigating. Further updates to follow shortly.

Mon 24 Nov, 2025 · 08:13 GMT

← Back