Connectivity issues for VMB customers

Major incident Broadband4 Internet Services for Education Broadband4 Leased Line Services Logi-Call Connectivity Services Logi-Call Leased Line Connectivity
Wed 22 Apr, 2026 14:19 BST · 23 hours, 21 minutes

Updates

Monitoring

VMB have identified an initial fault and implemented a fix. They are currently retesting impacted services and monitoring to ensure the fix has resolved all observed issues.

We’re observing all customer circuits back online. As VMB are still investigating this case, service should be regarded as “at-risk” until we provide further updates.

Wed 22 Apr, 2026 · 15:56 BST
Investigating

Virgin Media have confirmed that this issue is related to a Major Service Outage, affecting a large number of their customers. This MSO is being investigated by their engineers, and there’s currently no ETA on a resolution. We’ll provide further updates as we receive them.

Wed 22 Apr, 2026 · 14:53 BST
Issue

We’re currently seeing loss of service to leased lines provided via Virgin Media Business. We have raised an incident with VMB. We are also arranging for physical checks of the relevant ports to be carried out on both our and VMB’s equipment. Once we have further information, we’ll provide an update here.

Apologies for any inconvenience caused.

Wed 22 Apr, 2026 · 14:19 BST

← Back