Connectivity issues

Major incident Broadband4 Internet Services for Education Broadband4 Leased Line Services Broadband4 Filtering Services Broadband4 FTTP/FTTC/ADSL Services
Fri 08 Jan, 2021 15:12 BST · 16 minutes

Updates

Resolved

Services fully functional

Thu 04 Nov, 2021 · 15:24 BST
Monitoring

Services are back online. Engineers are continuing to monitor. Please accept our apologies for the disruption caused.

Thu 04 Nov, 2021 · 15:24 BST
Issue

We’re aware of issues with connectivity for some customers. Engineers are investigating and a further update will be posted shortly.

Thu 04 Nov, 2021 · 15:24 BST

← Back