Connectivity issues for some leased line customers

Major incident Broadband4 Internet Services for Education Broadband4 Leased Line Services Logi-Call Connectivity Services Logi-Call Leased Line Connectivity
Wed 09 Sep, 2026 11:14 BST · 19 hours, 18 minutes

Updates

Resolved

Fibre engineers completed repairs to the affected fibre at approximately 2:30am this morning.

Monitoring shows all impacted circuits back in service. Customers should regard this incident as resolved.

Should any further issues be observed, please raise a ticket with our helpdesk.

Please accept our apologies for any inconvenience caused during this outage.

Thu 10 Sep, 2026 · 06:22 BST
Investigating

The carrier’s network engineering team is on-site investigating the fault. They’re testing the fibre cables to locate the problem and reviewing technical records to help speed up the fix.

The next update is due after 17:30.

Wed 09 Sep, 2026 · 16:49 BST
Update

The carrier’s fibre splicing team was slightly delayed due to heavy traffic, but should now have arrived on-site to continue investigations with the network engineers. The next update is due after 16:30.

Wed 09 Sep, 2026 · 15:58 BST
Update

The carrier engineers are continuing to identify the precise location of the fibre break. A fibre splicing team is due to arrive on-site at 15:15. Next update after 15:30.

Wed 09 Sep, 2026 · 14:49 BST
Update

The carrier’s engineers have concluded their testing, with measurements showing a fibre optic cable break between two of their sites. A further update will be provided after 14:30.

Wed 09 Sep, 2026 · 13:39 BST
Investigating

The carrier’s engineers have arrived on-site and begun testing the affected fibre cables. A further update will be issued at around 13:30.

Wed 09 Sep, 2026 · 12:43 BST
Investigating

The carrier has now confirmed that they currently have a Major Service Outage (MSO) on part of their network, and have dispatched fibre engineers to diagnose the fault. Further updates will be provided.

Wed 09 Sep, 2026 · 11:35 BST
Issue

Engineers have observed connectivity issues affecting all leased lines provided by one of our carriers. We have already raised a fault with the supplier, and will update this status once we have further information.

Wed 09 Sep, 2026 · 11:14 BST

← Back