Exchange connectivity and Mailflow

Major incident MyCloud Services MyCloud Hosted Exchange Services
Mon 15 Feb, 2021 12:55 GMT · 21 hours, 26 minutes

Updates

Resolved

Mailflow and mailbox access issues were resolved yesterday afternoon.

Thu 04 Nov, 2021 · 15:24 GMT
Issue

We are currently aware of an issue affecting our hosted Exchange platform. Engineers are investigating and updates will be provided as they become available.

Thu 04 Nov, 2021 · 15:24 GMT

← Back