Outbound call issues for some customers

Major incident MyCloud Services MyCloud Voice Services
Fri 13 May, 2022 15:10 BST · 3 hours, 6 minutes

Updates

Resolved

Resolved

Fri 13 May, 2022 · 18:16 BST
Investigating

Issue was identified and confirmed as resolved earlier this afternoon. Please accept our apologies for the interruption in service.

Fri 13 May, 2022 · 18:15 BST
Issue

We’re aware of an issue affecting outbound calls from some customers. Engineers are investigating and we’ll post further updates as soon as we have further information.

Fri 13 May, 2022 · 15:11 BST

← Back